Investigating Reported Issues With Contact Form
Incident Report for Duda
Resolved
The reported issues of not receiving email notifications on contact form responses has been verified and resolved. No responses were lost, and all form responses can be downloaded from the widget, dashboard, or API. Email notifications have also been restored. If you continue experience any issues please reach out to the Support team.
Posted May 19, 2020 - 13:23 PDT
Update
We are continuing to investigate this issue.
Posted May 19, 2020 - 12:44 PDT
Investigating
We are currently investigating reports where customers are not receiving email notifications upon submittal of the Contact Form widget. Please note that submissions are not being lost and can currently be downloaded from the widget and dashboard.

Our engineering team is aware of the issue and working to identify the root cause and implement a solution as soon as possible. We will send an additional update as soon as we have more information.
Posted May 19, 2020 - 12:43 PDT