Sub-resource domain down
Incident Report for Duda
Resolved
All systems are operational at this time and this issue should be resolved.
Posted Feb 14, 2018 - 14:27 PST
Monitoring
We have resolved the issue with our domain provider and all resources should be coming back up, as the DNS propagates globally.
Posted Feb 14, 2018 - 14:05 PST
Identified
We are currently having problems with one of our internal domains (multiscreensite.com) that are used to host many sub-assets of websites (such as images, css & js files). This will cause some websites not load all assets properly.

We are working to resolve this with our domain provider currently to get all systems operational ASAP.
Posted Feb 14, 2018 - 13:05 PST