Duda Performing Annual Routine Maintenance

Incident Report for Duda

Resolved

The maintenance has been completed.
Posted Dec 27, 2020 - 05:17 PST

Monitoring

Duda is undergoing annual routine maintenance on December 27th. This means that starting 8am UTC the Duda Editor will be down and inaccessible. All live sites will remain up and unchanged. We expect this to last no more than 4 hours. If you have any questions or concerns prior to then, please contact Support.
Posted Dec 27, 2020 - 04:33 PST
This incident affected: Editor and API.