AWS Service Disruption

Incident Report for Duda

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 16:42 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 20, 2025 - 12:49 PDT

Update

We are continuing to investigate this issue.
Posted Oct 20, 2025 - 12:06 PDT

Update

We are continuing to investigate this issue.
Posted Oct 20, 2025 - 10:11 PDT

Update

We are continuing to investigate this issue.
Posted Oct 20, 2025 - 09:40 PDT

Update

We are continuing to investigate this issue.
Posted Oct 20, 2025 - 09:30 PDT

Investigating

We are currently experiencing issues with some services due to a disruption affecting Amazon Web Services (AWS). Our team is investigating and monitoring AWS’s status while working to mitigate impact.

Further updates will be provided as more information becomes available.
Posted Oct 20, 2025 - 09:30 PDT
This incident affected: Editor, API, Sandbox, and eCommerce.