Editor and live sites are down
Incident Report for Duda
Resolved
Sites and editors are operating normally after 3 minutes of downtime due to unplanned emergency maintenance done by our service provider
Posted May 13, 2018 - 02:08 PDT
Investigating
Editor and live sites are down, we are investigating
Posted May 13, 2018 - 02:04 PDT
This incident affected: Responsive Sites, Editor, API, and Mobile only sites.