Third Party Ecommerce (Ecwid) control panel loads slowly and new store creation doesn't work
Incident Report for Duda
Resolved
The issue has been resolved.
Posted Jul 20, 2023 - 05:17 PDT
Identified
Third Party Ecommerce (Ecwid) control panel loads slowly and new store creation doesn't work as a result of an outage of the third party provider.
The issues is being investigated.
Posted Jul 20, 2023 - 02:54 PDT
This incident affected: eCommerce.