Investigating Reports of Error Messages in the Duda Editor

Incident Report for Duda

Resolved

This issue has been resolved. If you are experiencing any additional issues, please reach out to support.
Posted Jan 08, 2026 - 12:49 PST

Monitoring

We have implemented a fix and will continue to monitor for instability and errors.
Posted Jan 08, 2026 - 10:37 PST

Investigating

We are currently investigating reports of errors and slowness in the Duda Editor. We will update here as soon as we have more information.
Posted Jan 08, 2026 - 09:16 PST
This incident affected: Editor.