Identified downtime on Native Booking and on automatic shipping rates of Native eCommerce

Incident Report for Duda

Resolved

We have confirmed all issues have now been resolved. If you continue to see any issues, please reach out to Support.
Posted Nov 18, 2025 - 11:01 PST

Update

We've identified that our Native Ecommerce's automatic shipping rate service, Easyship, is also being impacted by Cloudflare's issues
Posted Nov 18, 2025 - 05:59 PST

Identified

We've identified the service we use for our native Booking is experiencing downtime due to Cloudflare issues
Posted Nov 18, 2025 - 04:46 PST
This incident affected: Live Sites, Editor, and eCommerce.