Investigating Degraded Performance in Duda Editor

Incident Report for Duda

Resolved

This incident is now considered resolved.
Posted Jun 13, 2023 - 14:15 PDT

Monitoring

We are seeing improvements in the degradation of the impacted AWS servers. The Duda Editor is stable and we will continue to monitor for performance.
Posted Jun 13, 2023 - 13:57 PDT

Investigating

As a result of degraded performance reported by AWS, we are currently seeing degraded performance in the Duda Editor. As a result customers may experience issues with image uploads or other services. We are working to find a solution and implement as quickly as possible.
Posted Jun 13, 2023 - 12:38 PDT
This incident affected: Editor.