Can't create new SSL certificates
Incident Report for Duda
Resolved
We've found the issue and implemented a short term fix while we fix the root cause of too many renewal requests with LetsEncrypt.

New certificate generations will work as expected now.
Posted Jun 04, 2019 - 14:29 PDT
Investigating
New SSL certificates cannot be created currently. This applies to newly launched websites or websites looking to create a certificate but never had one.

Existing sites that already have an SSL certificate are working as expected.
Posted Jun 04, 2019 - 12:46 PDT
This incident affected: Responsive Sites.