Investigating reports that several App Store Apps are not able to be installed

Incident Report for Duda

Resolved

This issue has been resolved.
Posted Dec 26, 2025 - 13:30 PST

Investigating

We have received reports that several Apps in the Duda App Store are currently unable to be installed. We are investigating this issue and will provide an update as soon as one is available.
Posted Dec 26, 2025 - 11:35 PST
This incident affected: Editor.