Degraded Service – Duda Bookings

Incident Report for Duda

Resolved

This incident has been resolved.
Posted Jun 23, 2026 - 18:01 PDT

Monitoring

A fix to the previous incident impacting Duda Bookings has been implemented and we are now monitoring the results.
Posted Jun 23, 2026 - 10:17 PDT
This incident affected: eCommerce.