Investigating reports of form response notification emails blocked
Incident Report for Duda
Resolved
We were able to resolve the issue by changing the designated IP we use to send out emails.
Posted Sep 19, 2023 - 01:07 PDT
Investigating
It appears that one of the dedicated IPs Duda uses to send emails about new contact form responses has been blocked by some Internet Service Providers, causing form response emails to be blocked, filtered as spam or not seen in the inbox of the receiver.
We are working to remove this IP block and we will post updates as soon as we have them.
Posted Sep 18, 2023 - 05:49 PDT
This incident affected: Editor.