Investigating Reports of Image Manager not loading in Safari Browser

Incident Report for Duda

Resolved

The issue with the Image Manager not loading in Safari has been resolved.
Posted Sep 15, 2022 - 14:40 PDT

Investigating

We are currently receiving reports that the Image Manager is not loading for customers in the Safari Browser.

Our team is aware of the issue and working to identify the root cause and implement a solution as soon as possible.

Other browsers remain un-impacted.
Posted Sep 15, 2022 - 13:40 PDT
This incident affected: Editor.