Limited access to editing the Store/Ecommerce admin
Incident Report for Duda
Resolved
The issue has been resolved.
Posted Mar 22, 2022 - 04:04 PDT
Investigating
We are experiencing an issue preventing some of our customers from accessing the Ecommerce admin. Our developers are investigating the matter.
Posted Mar 22, 2022 - 03:30 PDT
This incident affected: Editor.