Ecommerce storefronts are partially not available
Incident Report for Duda
Resolved
This incident has been resolved.
Posted Apr 04, 2019 - 05:13 PDT
Investigating
Ecommerce storefronts are partially not available. Our development team has found the source of this issue and is in the process of restoring the service.

Estimated time of completing the restoration is 30 minutes.

Please accept our sincere apologies. All your store data will be kept intact and we will be posting updates here.
Posted Apr 04, 2019 - 04:15 PDT
This incident affected: Responsive Sites.