Identified - Store Control Panel and Live Store Issues

Incident Report for Duda

Resolved

Our third-party store provider has resolved the issue causing degraded performance on the Storefront and Store Admin page. All services are now operating normally. We will continue to monitor to ensure full stability.
Posted Oct 22, 2025 - 07:05 PDT

Investigating

Our third-party store provider has identified degraded performance on the Storefront and Store Admin page. Some live stores are also experiencing disruptions as a result, some store pages may not be active. Their team is actively investigating the root cause. We will provide updates as more information becomes available.

Native Duda stores are not effected and are operational
Posted Oct 22, 2025 - 02:06 PDT
This incident affected: eCommerce.