Investigating reports of degraded performance with collections

Incident Report for Duda

Resolved

This incident has been resolved.
Posted Jun 09, 2025 - 15:16 PDT

Update

We are continuing to investigate this issue.
Posted Jun 09, 2025 - 12:41 PDT

Investigating

We are currently investigating issues with collections and will provide an update as soon as possible.
Posted Jun 09, 2025 - 12:17 PDT
This incident affected: Editor.