eCommerce sites are loading slowly
Incident Report for Duda
Resolved
The incident has been resolved, eCommerce sites are working fine now.
Posted May 29, 2019 - 11:53 PDT
Identified
eCoommerce sites are loading slowly as a result of a problem our eCommerce provider is experiencing. We are working with our provider to solve the issue.
Posted May 29, 2019 - 11:36 PDT
This incident affected: Responsive Sites.