Images upload / retrieval issues
Incident Report for Duda
Resolved
All images problems have been resolved
Posted Sep 14, 2017 - 13:13 PDT
Investigating
We are seeing an increased rate of failures to upload images and to get uploaded images. This is a result of a problem Amazon Storage are having. See here - https://status.aws.amazon.com/
Posted Sep 14, 2017 - 12:20 PDT