Some live sites are down or very slow to respond
Incident Report for Duda
Resolved
The issue happened due to a DDoS attack. It is blocked now and the sites are up and running.
Posted Jul 14, 2020 - 03:49 PDT
Update
We are continuing to investigate this issue.
Posted Jul 14, 2020 - 03:46 PDT
Investigating
We are experiencing an issue of some live sites being down or very slow to respond. The team is investigating.
Posted Jul 14, 2020 - 03:43 PDT
This incident affected: Responsive Sites.