Difficulties accessing Duda's editor
Incident Report for Duda
Resolved
This incident has been resolved.
Posted Dec 09, 2020 - 17:02 PST
Update
We are continuing to monitor for any further issues.
Posted Dec 09, 2020 - 16:43 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 09, 2020 - 16:42 PST
Update
All Systems are up and running now, we continue to monitor our systems.
Posted Dec 09, 2020 - 16:40 PST
Investigating
We received several reports that the duda site editor is inaccessible at the moment, we are investigating the issue and will post an update shortly
Posted Dec 09, 2020 - 16:33 PST
This incident affected: Editor.